Results 1 to 6 of 6

Thread: Low FPS

  1. #1

    Default Low FPS

    Hi all

    I have a problem with low fps in Istaria.

    I run around 30fps, and in Bristugo lower than 20.

    My setup is

    I7 4790k
    32gb ddr 3 ram
    geforce gtx 1080ti
    and 512gb samsung ssd


    I tried to delete ClientPrefs_Graphic and ClientPrefs_Common with no luck.

    If i lower the viewdistance to 50% i get like 35fps.

    All i run in max, but when i lower it i wont get much more fps.

    I used to have ALOT more fps.

    If i run Istaria on my second screen thats are connected with the displayoutput on the motherboard HD4600 graphic i get arround 80fps


    Can anyone help me with why i am getting so low fps with my build? Should have alot more


    Best Regards
    Last edited by Abbie; February 26th, 2018 at 07:47 PM.

    Abbie: 100 Sorcerer, 100 Wizard, 100 Conjurer, 100 Chaos Warrior
    Rougee: 100 Shaman, 100 Cleric, 100 Guardian
    Warrior of the Blight Shard

  2. #2

    Default Re: Low FPS

    check to see if you have anything running in the background that'll use your video card like movie, mining ect
    Nodaken

  3. #3

    Default Re: Low FPS

    I dont have anything running in the background

    When i am running ark survival i am getting over 100fps in epic

    If i run istaria with the graphic from my cpy (hd4600) i get alot more fps, 80fps or more

    Its wierd

    Abbie: 100 Sorcerer, 100 Wizard, 100 Conjurer, 100 Chaos Warrior
    Rougee: 100 Shaman, 100 Cleric, 100 Guardian
    Warrior of the Blight Shard

  4. #4

    Default Re: Low FPS

    Quote Originally Posted by Abbie View Post
    I dont have anything running in the background

    When i am running ark survival i am getting over 100fps in epic

    If i run istaria with the graphic from my cpy (hd4600) i get alot more fps, 80fps or more

    Its wierd
    Istaria cannot take advantage of most current high-end GPU/CPU potential, where as most current games can. An example is that current istaria only works with 1 core of your CPU, so you could have a beastly quadcore or better, if its single core power isn't good it won't be any good for istaria.

    GPU wise there propably is a ton of things limiting it as well, I know that it hates NVIDIA cards for example, refusing to render or rendering a bunch of things wrong.

    One thing to up your FPS a lot though is changing up shadows to either not be there at all, or blob shadows only.
    By popular demand!

    Ranger isn't fun because it's only functional with one build built around one mechanic currently. Reaver isn't fun because it isn't well defined.

  5. #5

    Default Re: Low FPS

    Quote Originally Posted by meepsa View Post
    Istaria cannot take advantage of most current high-end GPU/CPU potential, where as most current games can. An example is that current istaria only works with 1 core of your CPU, so you could have a beastly quadcore or better, if its single core power isn't good it won't be any good for istaria.

    GPU wise there propably is a ton of things limiting it as well, I know that it hates NVIDIA cards for example, refusing to render or rendering a bunch of things wrong.

    One thing to up your FPS a lot though is changing up shadows to either not be there at all, or blob shadows only.
    I dont have shadows on. But for now i will play on my 22inch screen thats are connected up with my cpu graphic

    Abbie: 100 Sorcerer, 100 Wizard, 100 Conjurer, 100 Chaos Warrior
    Rougee: 100 Shaman, 100 Cleric, 100 Guardian
    Warrior of the Blight Shard

  6. #6

    Default Re: Low FPS

    Abbie you should get great FPS in istaria and it should run smooth with that video card. I have a GIGABYTE GeForce GTX 1060 G1 Gaming 6GB DirectX 12 GV-N1060G1 GAMING-6GD PCI Express 3.0 x16/6144 GDDR5/192-Bit and I get great FPS and the game has not dropped below 50 fps with mt 'create item widow' open. With the older system and the AMD card most times I would be down to 8-10 with create item window open and choppy. Running through Harro I would get 15-20 FPS and now I can do it smooth with 80-100 FPS. so smooth now.

    I found this link by Ractor. maybe take a look and see if some of it may help you.
    http://community.istaria.com/forum/s...Looks-(nVidia)

    Can't seem to link a screenshot

    Last edited by TheRock; March 14th, 2018 at 12:59 PM. Reason: screenshot pic didn't insert

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •