Results 1 to 3 of 3

Thread: Crafting bug - Missing or Invalid Machine (when actually on correct machine)

  1. #1

    Default Crafting bug - Missing or Invalid Machine (when actually on correct machine)

    I've been experiencing this bug on and off. It usually only happens when I'm scalecrafting, but today, it's started doing it when I was smelting.

    A few screenshots of this bug:

    Things to note:
    • I am clicking on the correct machine; see the screenshots.
    • I have the scalecraft/smelting buff applied (as appropriate for what I'm doing; smelting for making bars, scalecrafting for making dragonscales and deconstructing them)
    • It does not seem to matter whether I'm using a tool claw or regular claw; it does what it wants regardless.
    • Since I do most of my craft grinding outside of dralk, in that one event lair (, that's where I've experienced it most - however, I've also seen it do it on the essence chamber on the Isle of Wisps.

    I have tried:
    • Clicking other machines or other bits and pieces around the lair, and then going back to the machine to see if it'll update. Sometimes this works, sometimes this doesn't.
    • Closing the window, moving closer (or further) from the machine and then opening the window. No apparent effect.
    • Just closing and opening the window repeatedly. This usually does not work. It doesn't matter whether I double click it, or I go through the long way and search the menus for the right item.

    I have not tried:
    • Logging off and on because I am grinding and I don't have time for that.

    It usually resolves itself if I give it enough time, but I don't know for sure what causes it to start to work, or what causes it to stop working. I've returned recently, but this is not something I ever recall experiencing when I last played (however many years ago), so I am assuming this is a relatively new bug.

    Weird companion bug: every machine is the right machine (this only popped up when I doubled clicked the machine by accident, and I think my last crafting project came up.)

  2. #2

    Default Re: Crafting bug - Missing or Invalid Machine (when actually on correct machine)

    You are just too far from the crafting machine is all. Walk right up to it. No need to select it, just stand close enough and in the formula it will go from Red to White when you are in range.

    Wouldn't hurt if the machines effects stretched out an extra meter though.

  3. #3

    Default Re: Crafting bug - Missing or Invalid Machine (when actually on correct machine)

    The values under Resource, Have, Need, Base, Tech, Skill Used, etc is null (no value showing) in your screenshots.

    It might be a problem/bug? if you're double clicking the machine to bring up the item creation menu (is that what you're doing).?

    Have you tried to approach the machine, then open up a formula directly (either from Knowledge window, or a formula on a hotkey)? Does it still do that?

    I can't reproduce the empty values in your screenshot.
    Death points are temporary, Glory is forever!
    Need game info? Try Istaria Reference or Istaria Lexica Wiki

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Invalid machine icon on Isle of Ice
    By Cegaiel in forum Game Bugs
    Replies: 0
    Last Post: October 15th, 2014, 02:59 AM
  2. Reinstalling HZ on a new machine.
    By Vengeance in forum General Off Topic Posts
    Replies: 1
    Last Post: April 9th, 2008, 08:24 AM
  3. Machine won't boot up
    By Dobro in forum Hardware Discussions
    Replies: 8
    Last Post: July 29th, 2006, 05:47 PM
  4. What utilities do you use on your machine?
    By Khoal in forum General Off Topic Posts
    Replies: 12
    Last Post: April 4th, 2006, 10:14 PM
  5. Dev- Need a machine turned on please.
    By Deth in forum General
    Replies: 6
    Last Post: February 8th, 2006, 11:04 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts