Results 1 to 5 of 5

Thread: Weird graphical glitch/issue, even on fresh install

  1. #1

    Default Weird graphical glitch/issue, even on fresh install

    Getting a weird problem here - loaded up an old install and all the clickable buttons, window titles, and ALL the text in the "start button" are all garbled and mucked up.

    Downloaded a completely fresh install, copied nothing over, and it's exactly the same. Have already done a full-scan, as well.

    I saw another thread about this but without any answer. Anyone have any thoughts/suggestions?

    I'm also getting some bad flicker, which is usually related to framerate (on a 144hz monitor) but I don't see any options for vsync/frame rate adjusting within the settings. I also haven't had this trouble before with Istaria!

    Image linked shows the weird menus et al.

    https://imgur.com/7cSq76x

  2. #2

    Default Re: Weird graphical glitch/issue, even on fresh install

    Looking at the picture you have linked, it looks like you have experimental frame rates on. Why? Turn that off and try logging out and back on. Just a thought.

  3. #3

    Default Re: Weird graphical glitch/issue, even on fresh install

    On fresh installs and even creating a new character... You should un-maximize the window and re-maximize it again .

    That's the square icon on top right (next to X - to Exit Game). Your screenshot appears un-maximized now. Click the square icon to maximize it (and you might possibly need to unmaximize / re-maximize one more time).

    I'm not sure why you have to do that. It kind of forces the client to refetch the width/height of screen and put the correct aspect ratio on.

    The bad flicker, I'm not sure about. Maybe lower the Hertz. But the weird looking text, the maximize trick should work. Once you do that, you can start using it un-maximized again and resize it, if you want; but I find maximized view the best.
    Death points are temporary, Glory is forever!
    Need game info? Try: Istaria Reference (Info and Links to other resources)

  4. #4

    Default Re: Weird graphical glitch/issue, even on fresh install

    Quote Originally Posted by Slimey View Post
    Looking at the picture you have linked, it looks like you have experimental frame rates on. Why? Turn that off and try logging out and back on. Just a thought.
    I was toggling things on/off to try different stuff to see if anything affected the flickering. It happens with any game that isn't properly v-sync-ing to 144hz monitors, you get an awful and unpleasant flicker. Same deal with G-Sync on or off, sadly. :\

    The weird text thing happened on an old install and a new one, and I toggled between full screen, full screen windowed, and windowed but it still persisted.

    I logged in and swapped to windowed mode and toggled to/from maximized several times, to no avail. So no luck there, unfortunately.

    Okay, so it turns out I found the problem - UI Scale doesn't seem to work for some reason. Setting it to 'Normal' resolved the issue but, obviously, my UI is pretty darn tiny now (at 2560x1440). Easily reproducable by just changing the UI scale to different values.

    Also, in testing, I set it to 8x and the apply button is off the screen due to the size of the options window. :| None the less, the text works normal in 4x and 8x, but not 2x. Micro also works. The larger ones have some odd looking lines on the button textures, but the text is right at least.

  5. #5

    Default Re: Weird graphical glitch/issue, even on fresh install

    Quote Originally Posted by Losian View Post
    Okay, so it turns out I found the problem - UI Scale doesn't seem to work for some reason. Setting it to 'Normal' resolved the issue but, obviously, my UI is pretty darn tiny now (at 2560x1440). Easily reproducable by just changing the UI scale to different values.
    I play at the same resolution and never found a problem with the UI. Playing at windowed fullscreen on a 32" monitor.
    Research Assistant Pharaxes Sphaerideion (started playing 2007-09-08, ascended 2008-06-15)
    Dragon Adventurer: 100 (2009-01-05) Dragon Crafter: 100 (prior 2008-06-04)
    Dragon Crystalshaper: 100 (2013-12-21) Dragon Lairshaper: 100 (2013-09-28)

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Cannot patch after fresh install
    By Threxx in forum Help (Question and Answer)
    Replies: 2
    Last Post: July 18th, 2018, 11:54 PM
  2. Replies: 25
    Last Post: December 14th, 2016, 11:53 AM
  3. Replies: 3
    Last Post: February 2nd, 2014, 10:22 AM
  4. Fresh Install, WinXP, can't log in
    By LexDivinia in forum Help (Question and Answer)
    Replies: 8
    Last Post: August 27th, 2010, 04:34 AM
  5. Annoying graphical bug
    By Amerelium in forum General
    Replies: 9
    Last Post: March 20th, 2006, 12:22 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •